Xcode 4.3 on Lion with 10.4 sdk and gcc 4.0

February 19th, 2012

So, you get the latest generation of Mac which only support Lion and above, which only runs Xcode 4 or later, which is great. You have few old projects that use 10.4 sdk, which only compatible with gcc 4.0. You don’t want touch those project but want to be able to build them just as before. Here we are, copy few files and folders from your earlier Xcode instation into the /Applications/Xcode.app, you can build them as before.

1. Copy
/Developer/SDKs/MacOSX10.4u.sdk
into
/Applications/Xcode/contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

2. Copy
/Developer/usr/lib/gcc
to
/Applications/Xcode/contents/Developer/usr/lib/gcc (create the lib directory)

3. Copy
/Developer/usr/libexec/gcc
to
/Applications/Xcode/contents/Developer/usr/libexec/gcc

4. Copy
/Developer/usr/bin/*4.0* (any file name contains 4.0, about 9 of them)
to
/Applications/Xcode/contents/Developer/usr/bin/

5. Copy
/Developer/Library/Xcode/Plug-ins/GCC 4.0.xcplugin
to
/Applications/Xcode/contents/PlugIns/Xcode3Core.ideplugin/Contents/SharedSupport/Developer/Library/Xcode/Plug-ins/

One Response to “Xcode 4.3 on Lion with 10.4 sdk and gcc 4.0”

  1. Pasquale says:

    Do you know if it is possible to download those files and folders from the Apple Web site or from any other sites.

RSS feed for comments on this post. And trackBack URL.

Leave a Reply